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Overview of Release Preview Information

The Release Preview environment enables you to become familiar with the new features in an
upcoming release. You can verify that your existing business workflows function as expected
before upgrading the production account. You can also use the Release Preview environment to
test and ensure your NetSuite account and any associated applications are not dependent on a
specific data center to store data. You can evaluate your applications for any data center-specific
identifiers, and replace them with data center agnostic information.

Our goal is to provide a smooth and seamless transition to a new release. We hope that by
making this information available, working with you to ensure you perform the recommended
tests, and providing other needed guidance, we will avoid any major problems or surprises
when you go live with the new version.

To help you get the most out of your Release Preview, review the following topics:

• Preparing for Testing includes the following sections:

• New Visual Design for Version 2014 Release 2

• Setting Preferences for Release Preview Email

• Accessing Your Release Preview Account

• Functionality Available for Testing

• How to Report Issues

• Recommended Test Plan includes the following sections:

• Test Business Workflows

• Additional Tests
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Note: Performance in your Release Preview account is not always on par with your
production account. You can expect that the first few times you complete a process
or task, such as entering a sales order, performance will be a bit slow. You should
experience faster performance as you repeat the process or task through several
iterations of testing. Release Preview is intended for testing the functionality of new
features, not as a performance measurement tool for the new version.

Preparing for Testing
Important: As you prepare for testing in Release Preview, make a note of the various

scheduled events that run in your production environment. These scheduled
events should be disabled before the account is upgraded to the new release,
and enabled after the upgrade is complete.

To prepare for testing in Release Preview, review the following sections:

• New Visual Design for Version 2014 Release 2 describes changes in the user interface that
should be evaluated for any effects in your environment.

• Setting Preferences for Release Preview Email provides instructions for controlling email
generation from the Release Preview environment.

• Accessing Your Release Preview Account details how to access your Release Preview
account so that you can familiarize yourself with the new features and changes in this
release.

• Functionality Available for Testing contains a table of the features that can be tested in
Release Preview.

• How to Report Issues explains what to do if you encounter an issue.

New Visual Design for Version 2014 Release 2
In addition to the regular testing you do before every release, you need to prepare for the
changes introduced with NetSuite’s updated user interface. Be sure to take a look at the new
design in the Release Preview environment, so you can provide information to your users, and
re-optimize custom forms as needed.

It is especially important that you prepare for possible SuiteScript impact of user interface
changes. These changes have the potential to affect results for existing SuiteScripts. It is strongly
recommended that you thoroughly test all of your customizations in the Release Preview
environment, particularly client scripts, portlet scripts, and Suitelets. If you discover problems,
contact your account manager or file a support case. For more details, see the Version 2014
Release 2 Release Note SuiteScript Impact of Updated NetSuite User Interface.

For general information about the updated user interface, see the following:

• Preview Document: Prepare for the New UI in Release 2014.2

https://system.netsuite.com/core/media/media.nl?id=17497575&c=NLCORP&h=5b34873ad32db519595d&_xt=.pdf
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• Version 2014 Release 2 Release Note: New Visual Design for User Interface

• Help Topic: New User Interface for Version 2014 Release 2

Setting Preferences for Release Preview Email

Account administrators can set a preference for delivery of email messages for the Release
Preview environment in the production account, and also set your preferences directly in the
Release Preview environment on the Printing, Fax & Email Preferences page, on the Email tab.

For example, during testing you might not want customers to receive email messages from the
Release Preview account. In this case, you may want email from your Release Preview account
delivered only to yourself, or to the people in your organization who are responsible for testing.

To set email delivery preferences for Release Preview:

1. Log in to your NetSuite production account.

2. Go to Setup > Company > Printing, Fax & Email Preferences.

3. Click the Email tab.

4. Choose your preference in the Sandbox and Release Preview section. Under Release
Preview Options, choose from the following:

• Send Email To - Enter the address where email messages should be delivered.
You can enter multiple email addresses separated by commas. This preference is
recommended, as it enables you to specify each email address for routing email
messages from Release Preview.

• Send Email to Logged in User - Choose this option to route all email messages only
to the person logged in to the Release Preview account.

• Do Not Send Email - Choose this option if you do not want email messages sent
from the Release Preview account.

5. Click Save.

6. Your email delivery preferences will be applied to your Release Preview account.

Important: Release Preview is a copy of your production account as of a certain
date, so the data in Release Preview may not be the same as in your
production account. If you recently changed your Release Preview email
preferences in your production account, they may not be reflected in the
snapshot used to generate your Release Preview environment. Complete
the following steps to verify the email preferences in the Release Preview
environment.

7. Log in to your NetSuite Release Preview account.
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8. Go to Setup > Company > Printing, Fax & Email Preferences.
9. Click the Email tab.
10. Verify your email preferences in the Sandbox and Release Preview section, and if

necessary, modify them appropriately.

Accessing Your Release Preview Account
The Primary Contact and the Product Update contacts for your account receive several
notifications (by email, and upon login) in the weeks before the scheduled Release Preview
start date. These notifications contain details on the Release Preview and Upgrade dates, and
announce the day the Release Preview environment is available for testing to begin.

To access your Release Preview account:

1. Go to https://system.na1.beta.netsuite.com.
2. Log in using your usual email address and password.
3. Read the NetSuite Release Preview Agreement and click Continue to accept the terms

and access the Release Preview software.
4. Read the Version 2014 Release 2 Sneak Peeks and Release Notes 2014.2. documents so that

you have time to review new or changed functionality well before the release.

Note: These documents are also available in the New Release portlet.

5. Review Test Business Workflows and test your normal, day-to-day tasks as suggested in
the following sections to make sure there's nothing unexpected in the new version.

Note: The Release Preview environment is separate from your NetSuite production
environment. Use Release Preview only for testing. Be sure your are logged in to
your NetSuite production account when you are performing your daily business
activities.

Functionality Available for Testing
The following table describes functionality available for testing in the Release Preview. Only
modules that you have purchased and enabled in your production account will be available
in your Release Preview. Be sure you understand the limitations of the Release Preview
environment.

Note: “No actions taken” in the Limitations column indicates the feature is available, but
no emails are sent, no campaigns are executed, and no payments are processed.

Feature Availability Limitations

Integrations

CSV Yes  

http://www.netsuite.com/portal/landing/2014-2/platform.shtml#9
https://system.netsuite.com/help/helpcenter/en_US/PDF/ReleaseNotes_2014.2.0.pdf
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Feature Availability Limitations

SuiteAnalytics Connect (formerly
ODBC)

Yes  

Web Services Yes  

Customizations

Client SuiteScript Yes  

Custom Records Yes  

Scheduled SuiteScripts Available Scripts will not execute as scheduled, but can be
executed manually

Server SuiteScript Yes  

Partner Integrations

ACH Vendor Payments Available No actions taken

Credit Card Processing Test-mode only No actions taken

CTI Integration (Contactual,
Five9)

Yes  

Direct Deposit Available No actions taken

eBay Integration Available No actions taken

Electronic Funds Transfer Test-mode only No actions taken

Intellesync Yes  

Online Bill Pay No Automatically disabled in Release Preview

Outlook Integration No  

Payroll Available No actions taken

PayPal Integration Test-mode only No actions taken

Perquest Available No actions taken

Telephony Integration (Basic) Yes  

UPS/FedEx Integration for
Shipping labels

Test-mode only No actions taken

UPS/FedEx Integration for Rate
querying

Yes  

Miscellaneous Product Areas

Bulk Merge No No actions taken

Email Campaigns No No actions taken

Email Case Capture Yes  

Email Notifications No No actions taken

Fax No  

Memorized Transactions No No actions taken

Offline Client No Edit the Offline Client config file to point to a
different environment, if desired.



Release Preview Test Plan
Recommended Test Plan

6

Release Preview Test Plan

Feature Availability Limitations

Scheduled Saved Searches Available Set to inactive status

Secure Domains No Automatically disabled in Release Preview

SuiteFlow workflows No Automatically disabled in Release Preview

Web Site Yes  

Web Store Yes  

How to Report Issues

Report any issues you encounter during testing by calling NetSuite Support or by submitting a
case online.

To submit a case:

1. Go to the Support tab of your Release Preview account.

2. Click the Visit the SuiteAnswers Site link.

3. Click the Contact Support Online link and provide details of your issue.

A case will be created in the NetSuite Support system under your accounts that will be
flagged as a problem in the Release Preview environment.

Recommended Test Plan

Important: As you test in Release Preview, make a note of the various scheduled events
that run in your production environment. These scheduled events should
be disabled before the account is upgraded to the new release, and enabled
after the upgrade is complete.

The following sections provide a plan for thoroughly testing your account in Release Preview:

• Test Business Workflows explains how to document daily workflows, and provides a link
to a sample test plan.

• Additional Tests lists areas you should test if the workflow testing has not tested them
already, and outlines testing steps.

Test Business Workflows

In order to test successfully in Release Preview you should identify, document, and test the
key business workflows (not to be confused with SuiteFlow workflows) in your production
account. Testing your workflows is the most important aspect of Release Preview. Compile
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a list of the critical task paths your employees follow to get their jobs done and create a
document for each process. We recommend that you use a spreadsheet application and
create a separate worksheet for each common daily task. Use this spreadsheet as your
checklist during testing. The following link provides access to a Microsoft Excel worksheet,
a template for testing that includes a Testing Matrix, Workflow worksheets, and examples:
ReleasePreviewTestPlan_Template.xls. After downloading the file, you can modify it as needed
to suit your testing needs.

At minimum, each business workflow documented should contain the following components:

• Business Workflow Name: Provide a unique name

• Role: Specify the role to use when testing the process

• Email: Specify the email address to use for testing

• Steps: Provide the detailed navigation required to accomplish the desired task

• Results: List expected results

Additional Tests

If the business workflow testing did not exercise all the areas of your account, you may need to
perform additional tests. The areas to verify are described in the following sections:

• Test Custom Reports and Forms

• Test Custom Centers

• Test Other Customizations

• Test SuiteScript

• Test SuiteTalk (Web Services) Integrations

• Test Installed SuiteApps

• Test Your Web Store

• Test ODBC

Test Custom Reports and Forms

Pay particular attention to any Customized Reports, Customized Forms, Custom Record
Types, Custom Searches, or bulk operations such as billing, shipping, and fulfillments. Compile
checklists of reports, forms, record types, and other customizations from your production
account.

https://system.netsuite.com/core/media/media.nl?id=20928182&c=NLCORP&h=d7dbb1463ed906352939&_xt=.xls
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Important: Your custom forms should work as expected in Version 2014 Release 2, but
the new visual design will cause the layout change, especially on longer
vertical pages. You might need to optimize some of your forms for the new
visual design, for example, when there are many custom fields all in the
clustered in the main body section. Administrators should take the time
look at the most commonly used custom forms. Recommendation: set the
browser zoom mode to 75% if there are issues with viewing some forms.

To test custom reports and forms:

Note: Performance in the Release Preview account may differ from your production
account because it runs on different hardware. If your reports or searches run
more slowly in the Release Preview, reduce the date ranges for those searches and
reports. Your testing goal is to ensure that everything functions as expected: the
filtering, formulas, and the sorting of each report or search.

1. Create checklists for various customized reports, forms, record types, and searches. See the
following sections for specific procedures for creating checklists.

2. Test each form, each script, and each report that uses a formula to ensure they behave as
expected. If any customized form, script, or report uses a formula, ensure the formula
results are the same as in your production account. For example, run the identical report
in your production account and in the Release Preview account. Compare formula
columns from the two reports to verify that the results are the same. Check off each item
in your checklists after testing.

Important: Release Preview is a copy of your production account as of a certain
date, so the data in it may not be the same as in your production
account. We recommend that you generate reports using date ranges
that can be compared between both accounts.

3. Verify that any custom fields or custom record types function as expected. For example,
for each custom record, ensure that:

• Add and Delete behavior is the same as in the production account

• A record is linked appropriately to a parent record

• Formulas and forms function as expected

4. Check Dashboard functionality: KPIs, KPI Scorecards, Report Snapshots, and other
customizations.

5. Test your custom business workflows from start to finish. See Test Business Workflows for
more information.

6. Test Suitelets and custom dashboard portlets.  If these customizations do not use
SuiteScript UI Objects, and if you have written custom HTML, verify they work as
expected in the Release Preview environment.
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To create a checklist for testing Transaction Forms customizations:

1. Go to Customization > Forms > Transaction Forms.

2. Export this list to CSV or .xls.

3. Review the list, and remove any items labeled Customize in the Edit column, as those are
NetSuite defaults.

4. Save this modified list as your checklist for testing.

To create a checklist for testing Entry Forms customizations:

1. Go to Customization > Forms > Entry Forms.

2. Export this list to CSV or .xls.

3. Review the list, and remove any items labeled Customize in the Edit column, as those are
NetSuite defaults.

4. Save this modified list as your checklist for testing. Make a note of any form that is linked
to SuiteScript and Script Libraries, and ensure you test these forms.

Note: It is not necessary to test custom forms that you no longer use.

To create a checklist for testing Record Types customizations:

1. Go to Customization > Lists, Records & Fields > Record Types.

2. Record types cannot be exported, so we recommend you make a list of them in an Excel
spreadsheet to use as a checklist to ensure that you test each record type.

To create a checklist for testing Lists, Records, and Fields customizations:

Note: Most of these lists will be visible when testing your forms, but make note of them
for reference.

1. Go to Customization > Lists, Records & Fields > Lists.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

2. Go to Customization > Lists, Records & Fields > Entity Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

3. Go to Customization > Lists, Records & Fields > Item Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

4. Go to Customization > Lists, Records & Fields > CRM Fields.
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If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

5. Go to Customization > Lists, Records & Fields > Transaction Body Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

6. Go to Customization > Lists, Records & Fields > Transaction Column Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

7. Go to Customization > Lists, Records & Fields > Transaction Item Options.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

8. Go to Customization > Lists, Records & Fields > Item Number Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

9. Go to Customization > Lists, Records & Fields > Other Custom Fields.

If desired, export this list to CSV or .xls. Save this list as your checklist for testing.

To create a checklist for testing Reports and Saved Search customizations:

1. Go to Reports > Saved Reports > All Saved Reports.

2. This data cannot be exported. Make a list of all your customized reports in an Excel
spreadsheet to use as a checklist.

3. Go to Reports > Saved Searches > All Saved Searches

4. This data cannot be exported. Make a list of all your customized searches in an Excel
spreadsheet to use as a checklist.

Test Custom Centers

In the Release Preview, Custom Center links are hard-coded from your production account,
for example, the links do not include na1.beta. in the domain name as found in the Release
Preview URL. Therefore, when you click custom center links in Release Preview, those links
will load pages from your production account instead of the pages from Release Preview.

In order to test pages available from Custom Center links in Release Preview, add na1.beta to
each link as follows:

Change: https://system.netsuite.com/pages/customerlogin.jsp?country=US

to: https://system.na1.beta.netsuite.com/pages/customerlogin.jsp?country=US

Test Other Customizations

Areas to test in this section include:



Release Preview Test Plan 11

Release Preview Test Plan

• Test SuiteScript

• Test SuiteTalk (Web Services) Integrations

• Test Installed SuiteApps

How you test other customizations depends on who implemented the customization and
whether you are still engaged with that company.

For NetSuite Professional Services Customizations:

• If you are still engaged with NetSuite Professional Services on this work, please contact
them or inform NetSuite Support. Support will make Professional Services aware of your
Release Preview dates so that they can coordinate testing with you.

• If the custom work has been signed off by you and you use it in your day-to-day routine,
engage your internal person who maintains the customization to test it out in Release
Preview.

For Third-party (Independent Software Vendor) Customizations:

• If you are still engaged with the third-party on this work, we recommend you make them
aware of your Release Preview dates and request their assistance in testing the custom
work.

• If the custom work has been signed off by you and you use it in your day-to-day routine,
engage your internal person who maintains the customization to test it out in Release
Preview.

Test SuiteScript

Read the SuiteScript release notes for details on API changes.

For Version 2014 Release 2, you should be aware of the following changes related to the new
visual design:

• SuiteScript has never officially supported direct access to the DOM. If your scripts are
accessing the DOM, they may no longer work as expected.

• Quirks mode has been turned off. Quirks mode allowed backward compatibility with
older browsers, instead of enforcing compliance with W3C and IETF standards. Validate
your custom HTML and scripts’ compatibility with HTML5 standards.

For more details, see the Version 2014 Release 2 Release Note SuiteScript Impact of
Updated NetSuite User Interface.

To test SuiteScript:

1. Go to Customization > Scripting > Scripts.
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List all scripts in an Excel spreadsheet to use as a checklist to ensure that you test each one.

2. Go to Customization > Scripting > Script Deployments.

List all script deployments in an Excel spreadsheet to use as a checklist to ensure that you
test each one.

3. Go to Customization > Scripting > Scripted Records.

List all scripted records in an Excel spreadsheet to use as a checklist to ensure that you test
each one.

4. Test all of your operational SuiteScripts for compatibility and to ensure they are working as
expected.

5. If you find any issues with your Server SuiteScripts you can put the script deployment in
testing mode and use the debugger on the na1.beta domain to investigate the problem.

The SuiteScript Debugger URL for your Release Preview account is https://
debugger.na1.beta.netsuite.com

Important: Changes you make to your account while in the debugger.na1.beta
domain will affect your Release Preview account only and will NOT affect
your production account.

Test SuiteTalk (Web Services) Integrations

Test any operational Web Services Integration processes for compatibility. If you are engaged
with a partner for any of your Web Services integrations, please contact them and inform
them of your Release Preview dates so that they can provide a time and test plan to test the
integration.

To test your Web Services application in the Release Preview account, change the version
number and add .na1.beta. to your endpoint URL.

For example, change the URL from:

https://webservices.netsuite.com/services/NetSuitePort_2014_1

to:

https://webservices.na1.beta.netsuite.com/services/NetSuitePort_2014_2

The currently supported Web Services versions are:

• https://webservices.na1.beta.netsuite.com/wsdl/v2014_1_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2013_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2013_1_0/netsuite.wsdl
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• https://webservices.na1.beta.netsuite.com/wsdl/v2012_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2012_1_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2011_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2011_1_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2010_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2010_1_0/netsuite.wsdl

The following Web Services versions are considered to be deprecated:

• https://webservices.na1.beta.netsuite.com/wsdl/v2009_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2009_1_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2008_2_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2008_1_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2_6_0/netsuite.wsdl

• https://webservices.na1.beta.netsuite.com/wsdl/v2_5_0/netsuite.wsdl

Test Installed SuiteApps

If you have SuiteApps installed in your account, make sure you test these applications in
Release Preview. For third-party applications installed in your account, please contact the
solution provider and inform them of your Release Preview dates. Make sure you test all critical
business workflows that rely on the third-party solution and inform the solution provider of
any issues you may find.

Test Your Web Store

Perform the following configuration procedures to test your web store in Release Preview.

Important: To prepare for web store testing in Release Preview, in the following
procedure you will add a line to the hosts file. Be sure to remove this line after
you finish testing.

To test your web store:

1. Open a command window.

2. Type ping shopping.na1.beta.netsuite.com and press Enter to obtain the IP address for
Shopping.na1.beta.netsuite.com
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3. Edit the hosts file on your C drive:

a. At the prompt in the command window, type

cd Windows/system32/drivers/etc/ and press Enter.

b. Edit the hosts file by typing edit hosts and press Enter.

c. Add a line to hosts file using the IP Address you obtained from the ping
shopping.na1.beta.netsuite.com command. For example:

64.89.45.224 mydomain.com

d. Select File > Save.

e. Select File > Exit.
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4. Log in to your NetSuite account and go to Setup > Site Builder > Domains and specify the
following properties:

a. Domain name = <mydomain.com>

b. Hosted as = Web Store

c. HTML Hosting Root = Live Hosting Files

The site or page should populate with the company name.

5. Click Save.

6. Go to Setup > Site Builder > Set Up Web Site. Verify that the URL for your custom domain
is indicated as Primary.

7. Open a browser window. Visit the web store on your custom domain.

Note: If you visited this domain recently, you may have to clear the browser cookies.

8. Confirm you are viewing your site on the Release Preview shopping server.

a. In your browser, select View > Source (or right-click and select View Page Source).

b. At the bottom of the source code page, you should see the new version number for
the NetSuite release.

9. Test your web store.
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Important: Be sure to remove the line you added to the hosts file after you complete
web store testing.

Test ODBC

Perform the following configuration procedures to test your ODBC connection in Release
Preview.

Important: To prepare for ODBC testing, in the following procedure you will switch the
Service Host entry to connect to the Release Preview environment. Be sure
to switch the Service Host entry back to your production account after you
finish testing ODBC in Release Preview.

To test ODBC access in your Release Preview account:

1. Log out of your current ODBC connection.

2. In the Windows Control Panel, double-click Administrative Tools, and double-click Data
Source (ODBC).

3. In the ODBC Data Source Administrator dialog, select the User DSN for the NetSuite
ODBC driver, and click Configure.

4. In the Driver Setup dialog, change the Service Host entry from odbcserver.netsuite.com
to odbcserver.na1.beta.netsuite.com.

5. Click OK in both dialogs.

6. Reconnect your ODBC connection.

7. Perform your ODBC tests.

Important: Be sure to switch the Service Host entry back to
odbcserver.netsuite.com in order to connect to your production
account.
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